当前位置:首页 > 问答

通达信公式彩macd

我来帮TA回答

通达信软件里MACD金叉死叉用红色和绿色小箭头表示的公式

这些没有用的,别在这上面害自已了。多看经典书,长线投资才是正道 。我研究了十年图表技术分析,什么时间机构进出都能从图上看出来,可是一点用都没有,还使自已亏钱。做股东,面向企业的投资才是正道 。

求一个通达信MACD自动选股公式

你好,有的。DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);DEA := EMA(DIFF,9);MACD := 2*(DIFF-DEA);select:cross(diff,dea) and dea>-1.0 and dea<0.5 and CLOSE>ref(CLOSE,1) and CLOSE>=ma(c,60);
或:
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); XG:DIF>0 AND DEA>0 AND CROSS(DIF,DEA);
不足之处,多多交流。

请大侠修改通达信公式:使得MACD柱线和DIFF与DEA二条线所围成的彩色块互不遮盖。

通达信公式的画线方式,是后面的代码画在上面,前面的代码画在下面,所以你的这个问题很好解决,方法是将MACD柱线放到代码的最后即可,修改后的代码如下:
DIFF1:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1 :EMA(DIFF1,9);
DRAWBAND(DIFF1,RGB(150,80,100),DEA1,RGB(256,150,100));
DIFF:DIFF1,COLOR999999,LINETHICK1;
DEA:DEA1,COLOR00FFFF,LINETHICK1;
MACD :2*(DIFF1-DEA1),COLORSTICK;

通达信指标编写macd

通达信指标编写macd
macd的dea持续20天大于0,且macd大于0
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
XG: EVERY(DEA>0 AND MACD>0,20);
回答完毕。
https://kuaibao.qq.com/s/20190123A18T8200
轻松学会用通达信软件编写公式和指标

谁能帮我编个macd底背离的选股公式,不盛感激!

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIFF:=SUM(MA1-MA2,0);
SUMMACD:=SUM(MACD,0);
W1:=BARSLAST(CROSS(MA2,MA1))+1;
W2:=BARSLAST(CROSS(MA1,MA2))+1;
W3:=BARSLAST(CROSS(MACD,0))+1;
W4:=BARSLAST(CROSS(-MACD,0))+1;

趋势力度:IF(K,SUMMACD-REF(SUMMACD,MIN(W3,W4)),DIFF-REF(DIFF,MIN(W1,W2)));
趋势平均力度:趋势力度/IF(K,(MIN(W3,W4)+1)/20,(MIN(W1,W2)+1)/20),COLORSTICK;
MAX趋势平均力度:HHV(趋势平均力度,34);
MIN趋势平均力度:LLV(趋势平均力度,34);
--------------------------------------------------------------------------------------------------------------------------------------------
K值可调,调成“0”是通过均线缠绕面积判断背驰
调成“1”是通过macd面积判断背驰。
白线为均线(或macd )到目前为止的面积,白线的拐点(即某一段的最大值(绝对值))是均线或macd面积。如果K调成1,红绿柱为凭据趋势力度。

此指标不是选股指标,是个副图指标,因为选股指标需要判断前后面积的大小,难度极大,不易做出,目前还没发现有人能写出来。

用MACD 底背离 选股?

对于技术投资者来说,MACD底背离是最好用的,特别是周线,如果公司不破产,50%+的利润不成问题,不管是中国、美国还是香港,你随便验证,成功率不会低于80%。当然如果公司玩不下去……